Medibuntu, de nouveaux dépôts pour les applications propriétaires

Annoncé par racoon97, Medibuntu vient d’être mis en place après l’arrêt par le plf du support Ubuntu. Les dépôts sont prévus pour breezy, dapper et edgy.

Pour obtenir la clé d’authentification gpg et l’ajouter au trousseau :

wget -q http://medibuntu.sos-sts.com/repo/medibuntu-key.gpg -O- | sudo apt-key add -

Éditer le fichier sources.list, et sélectionner les dépôts suivant la version d’Ubuntu que vous avez installée :

sudo nano -B /etc/apt/sources.list

L’option -B réalisera une sauvegarde du fichier avec l’extension ~. CTRL + o pour enregistrer (avec le même nom), CRTL + x pour quitter.

Pour breezy :

## Medibuntu - Ubuntu 5.10 "breezy badger"
## Please report any bug on https://launchpad.net/products/medibuntu/+bugs
deb http://medibuntu.sos-sts.com/repo/ breezy free non-free
deb-src http://medibuntu.sos-sts.com/repo/ breezy free non-free

Pour dapper :

## Medibuntu - Ubuntu 6.06 LTS "dapper drake"
## Please report any bug on https://launchpad.net/products/medibuntu/+bugs
deb http://medibuntu.sos-sts.com/repo/ dapper free non-free
deb-src http://medibuntu.sos-sts.com/repo/ dapper free non-free

Pour edgy :

## Medibuntu - Ubuntu 6.10 "edgy eft"
## Please report any bug on https://launchpad.net/products/medibuntu/+bugs
deb http://medibuntu.sos-sts.com/repo/ edgy free non-free
deb-src http://medibuntu.sos-sts.com/repo/ edgy free non-free

sudo aptitude update ou sudo apt-get update

Et voilà :)

6 thoughts on “Medibuntu, de nouveaux dépôts pour les applications propriétaires

  1. kwakosaure

    aptitude ne pose pas de problème si on utilise régulièrement synaptic ?
    J’avais entendu dire que apt-get et aptitude n’étaient pas complètement compatibles, t’as des infos là-dessus ?

  2. bapoumba

    Si tu installes A qui dépend de B et C, puis le désinstalles, avec apt-get seul A sera désinstallé. Si B et C ne sont les dépendances d’aucun autre paquet, A, B et C seront désinstallés avec aptitude. Donc plus besoin d’utiliser deborphan puisqu’il n’y a plus de paquets orphelins.

    Par contre, mixer les deux n’est pas recommandé, puisqu’ils ont chacun leur «base» et ça risque de mettre le bazar.

    Disons que tu installes A, et les dépendances B et C, avec aptitude.
    Puis tu installes D, qui dépend de B avec apt-get. No problemo.
    Maintenant tu désinstalles A avec aptitude, qui ne sait pas que D est là, et qu’il a B en dépendance. A, B et C sont désinstallés, tu mets le bazar dans D :/

    Par contre, si D est installé avec aptitude, en désinstallant A, seul C sera désinstallé aussi.

    Je peux me tromper, mais c’est ce que j’ai compris.
    Depuis edgy, que j’ai réinstallée à partir du CD alternate, je n’utilise qu’aptitude, y compris pour les upgrades annoncées par l’update manager (qui travaille avec apt-get).

    Donc pas de mix entre les deux. Faut que je retrouve le nom de la «base».

  3. bobbybionic

    Si c’est sympa de mixer les deux, je m’étais amusé à faire croire à aptitude que la quasi totalité de mon système dépendait d’un paquet “tout c++”, je ne me souviens plus lequel, c’était du temps où je faisais mumuse avec xubuntu :-)

  4. Camille Bourgoin

    depuis edgy apt-get gère la suppression des paquets jugés “non utilisés” ;)

    Sinon je confirme : passer d’apt-get à aptitude, c’est assez sportif !

    Très joli ce blog Bapoumba ! Les couleurs sont très bien choisies, le style épuré et clair, impéc :)

Comments are closed.